如何将路由器从多媒体箱里移出来


需求分析

买的二手房,原业主在装修的时候,网络布线状况是,每一个房间和有网口的地方有一根网线连接到弱电箱,弱电箱在入户门口。

我希望家里可以实现:每个宽带插口可以直接进入同一个网段形成家庭网络并上网,全房间有wifi,有线网络实现千兆网速,无线wifi 2.4G+5G并存,同时提供一个guest wifi给客人单独使用,权限上guest wifi只能上网无法访问本地局域网资源。

但现实遇到的问题是,多媒体箱到电视柜只布了一根网线,这根网线还被IPTV占用了,那么要实现所有网段都在同一个主路由下运行,就需要把主路由器放到多媒体箱里。也就是 光猫 ---> 路由器 ---> 交换机 ---> 多个房间。

但大家都知道,路由器放到多媒体箱,势必影响无线信号,而且现在的千兆无线路由器也比较大,多媒体箱根本也放不下。客厅电视柜其实在房子比较中心的位置,想把路由器放到那里最合适,如何把路由器从弱电箱移到客厅,那么就需要,用一根网线,做到三路复用:
1. IPTV信号传输到电视柜IPTV机顶盒
2. 连接光猫和无线路由器,让无线路由器解析成内网。
3. 无线路由器解析后的内网传送回多媒体箱的千兆交换机,让各个房间的有线接口都工作在同一个路由器下的同一个局域网。

那么问题来了,如何做到一根网线三路复用而且信号不干扰呢?那就需要用到虚拟局域网VLAN技术

使用VLAN交换机将路由器移出来

先看一下成型的网络拓扑图

划分网段

整个家庭网络划分出三个VLAN,VLAN Id分别是:
1:内网,上图蓝色线表示
2:外网,未经路由器解析过的信号,上图红色线表示
3:IPTV,光猫解析后传输IPTV信号到IPTV机顶盒

硬件设备

整个家庭网络,因为设备比较多,能有线千兆传输的就有线接入了,比如书房的台式机、下载宝(送的)、以前的小米路由器(现在当NAS和有线AP用)等等,一共用了3个千兆交换机,一般两个其实就足够。
1. 多媒体箱里的网件GS108E ,支持VLAN
2. 电视柜的网件GS105E,支持VLAN
3. 书房的网件GS108,注意这个型号没有"E",只是个单纯的千兆交换机,不支持VLAN,闲鱼80块钱买的二手的,带E的要贵很多,而且书房的不需要VLAN,为了省钱。

线路

家里接的网线看了下基本是超五类,对于家庭局域网传输距离来说,跑千兆问题不大。
为了方便管理,给自己设定了几个原则:
1. 每个交换机都是用最后一个端口作为跟其他网络硬件的通信用
2. 两个VLAN交换机,1号端口都作为外网传输使用,2号端口都作为IPTV信号传输使用。
3. 其他端口作为内网传输使用,接上网的各种终端设备,比如PC、下载宝等。

配置VLAN

配置基于802.1Q的VLAN,操作步骤参考 网件官方文档

配置结果:

多媒体箱交换机GS108E VLAN配置

电视柜交换机GS105E VLAN配置

路由器设置

R8500刷梅林

这里就不啰嗦,网上有很多现成的,刷梅林基本一个套路,我买的路由器是网件R8500,有现成的。//koolshare.cn/thread-94876-1-1.html

配置DHCP分配方案

我家庭网络中:
* 主路由DHCP分配区域是192.168.1.21~192.168.1.254,这些给上网终端设备。
* 留192.168.1.2~192.168.20用于手动分配给网络交换设备,比如VLAN交换机、AP、二级路由等。

小米路由作为二级路由实现远程下载

为什么还要用小米路由呢?
1. 家里之前用的百兆小米路由R1D,带一个1T的硬盘,虽然现在有了更NB的千兆路由,但期望老设备能发挥余热,作为一个简单的家庭NAS使用,同一个路由设备下面所有的设备可以访问共享硬盘,这样可以通过小米路由App远程下载电影,让小米盒子访问NAS播放电影。
2. 把小米路由放到书房,作为有线AP接入,放大书房的wifi信号。

但小米这家公司吧,你懂的,为了米家生态,把基于OpenWrt的路由器改了不少,导致如果你不把小米当成主路由使用,就无法通过App远程下载,同级网络其他设备也无法访问硬盘。这个其实是小米路由器的防火墙策略导致,可惜小米也没开放修改防火墙的界面,需要自己SSH登录手动修改。步骤如下。

小米路由通过有线中继接主路由

小米路由器的Wan口接墙上的接口,其实通过交换机接到主路由的Lan口。

主路由分配静态IP给小米路由器

这里我给小米路由分配的是192.168.1.5,记住这个IP,后面会用到。

打开小米路由的SSH

详情参考 //www1.miwifi.com/miwifi_open.html

修改samba配置文件

修改 /etc/samba/smb.conf.template,修改如下属性。

interfaces =127.0.0.1/255.0.0.0 lo 192.168.1.5/255.255.255.0 br-lan
bind interfaces only = no

修改防火墙配置

修改 /etc/config/firewall 和 /etc/config/firewall_default
option output 'REJECT' 修改为ACCEPT

config zone
        option name 'wan'
        option network 'wan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

另外,在这俩文件末尾增加如下内容:

config rule 'WANSHARETCP'
        option src 'wan'
        option dest_port '137 138 139'
        option proto 'tcp'
        option target 'ACCEPT'
        option name 'WANSHARE TCP'

config rule 'WANSHAREUDP'
        option src 'wan'
        option dest_port '137 138 139'
        option proto 'udp'
        option target 'ACCEPT'
        option name 'WANSHARE UDP'

重启路由器

顺利的话,大功告成。同时在小米路由器App里,能看到家里所有的同级网络设备,不过连接方式显示有线连接,可能是因为小米路由自己是有线连接的原因吧。

试试远程下载,速度还可以。